解决多个php版本共存问题 php -v和phpinfo不同版本 composer与php think版本问题


这次处理的问题是服务器环境中安装的多个php版本环境,导致php -v和phpinfo文件看到两个不同的PHP版本,导致composer与php think会报出版本低的错误。我们需要将其中一个PHP版本限制掉只使用一个PHP版本。

第一、查看当前php.ini

find  / -name  php.ini

第二、添加变量默认php版本

vi /etc/profile

export PATH="/www/server/php/71/bin:$PATH"

source /etc/profile

这里可以看到php -v和phpinfo是一样的PHP版本,问题可以得到解决。

声明:祁志飞||小祁的博客|版权所有,违者必究|如未注明,均为原创|本网站采用BY-NC-SA协议进行授权

转载:转载请注明原文链接 - 解决多个php版本共存问题 php -v和phpinfo不同版本 composer与php think版本问题


QQ:137867590